Last builds of BIAS Amp / FX for Apple Legacy OS

For OSX10.7 and OSX10.8 users, you can download the last builds of BIAS Amp and BIAS FX here.

BIAS AMP for Apple Legacy OS

BIAS FX for Apple Legacy OS

 

Was this article helpful?
10 out of 14 found this helpful
Need More Help? Contact Us

Comments