Supported Android Devices For Spark App

Please click HERE to download the full list of supported Android devices for the Spark app.

*Please note, the Spark app requires Android 8.0 or above.

Google has also stopped supporting Android 7 Nougat upon the release of Android 10.

If you'd like to use the Spark app with mobile devices running Android 7, please consider upgrading the OS.

 

Was this article helpful?
107 out of 226 found this helpful
Need More Help? Contact Us